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About the Tool 
The Roster Reconciliation Tool was developed by Dr. Kevin Brophy and Dr. Alex Duong with support from 
the Ontario Medical Association (OMA), and the Section on General and Family Practice (SGFP). The 
purpose of the Excel-based Roster Reconciliation Tool is to help physicians and their teams identify 
discrepancies between their EMR patient roster and the Ministry of Health (MOH) roster. OntarioMD 
(OMD) developed instructions for using the Roster Reconciliation Tool, EMR searches to complement the 
tool, and assembled all these components into a convenient toolkit for physicians.  

The Roster Reconciliation Tool works with patient roster files extracted from QHR ACCURO®, TELUS CHR, 
TELUS PS Suite (PSS), and OSCAR Pro EMRs. 

Who Can Benefit from the Toolkit 
• Family physicians working in rostered primary care models (FHO, FHG, FHN) 
• Clinic administrators responsible for roster management 
• OMD Advisors or practice facilitators supporting clinicians to improve their roster accuracy 
• Ontario Health Team (OHT) partners assisting in enrollment cleanup 

Why Roster Reconciliation Matters 
Accurate patient rostering and regular reconciliation are vital for maintaining panel accuracy and 
ensuring patients are properly attached to care. Proactive roster reconciliation helps physicians maintain 
a clear understanding of their patient panel, supports high-quality primary care delivery, appropriate 
resource allocation, and optimized remuneration. 

Roster reconciliation also reduces administrative burden, improves data quality, and ensures that reports 
and performance metrics reflect the most current patient information. 

Before You Begin 
Working from the computer where roster reconciliation activities will take place, you will need: 

• Internet access 
• Microsoft Excel (desktop version, Windows PC) installed 

Note: The tool contains macros that may not work on older Excel versions, web-based Excel, or on MAC 
computers. 

• EMR access and permissions to download/import and run EMR reports. The feature depends on 
your EMR system: 

o OSCAR Pro: Report by Template (RbT) 
o QHR ACCURO®: Query 
o TELUS CHR: Analytics Dashboard 
o TELUS PSS: Search 

• Login credentials and permissions to download roster files from the Ministry of Health (MOH) via 
the Medical Claims Electronic Data Transfer (MC EDT) system, accessed through the OPS BPS 
Secure portal (formerly GO Secure). 

mailto:support@ontariomd.com?subject=Roster%20Reconliliation%20Toolkit
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Note: Depending on your EMR, some clinics may be able to access MOH roster files directly from their EMR 
billing modules (if available in your EMR). 

• Download and extract the zipped Roster Reconciliation Toolkit to your local computer. 

Toolkit Contents 
• The main folder, Roster Reconciliation, contains: 

• Subfolders: 
o EMR Report 
o MOH Report 
o Reconciliation Cleanup – TO DO 

• Help File: Roster Reconciliation Instructional Guide 
• Roster Reconciliation Tool 1.2.xlsm (Microsoft Excel Based Tool) 
 
• EMR Search Files: 

o OMD Roster Reconciliation-EMR Report - OSCAR PRO 
o OMD Roster Reconciliation-EMR Report - TELUS PSS 

 
Note: After importing or saving applicable search files into your EMR, you may delete them from your locally 
saved Roster Reconciliation folder. 

 
EMR Users of: 
• QHR ACCURO® Query: Download OMD Roster Reconciliation-EMR Report from the ACCURO® Alert 

Publisher. 
• TELUS CHR Analytics: Define and run the analytics dashboard within the EMR each time you require 

a new EMR Report (see EMR Report section). 
 
Files needed to run the Roster Reconciliation activities include: 

• Active, rostered patient list by physician exported from the EMR  
• Recent roster capitation report from the Ministry of Health (MOH) 
• Roster Reconciliation Tool 

Roster Reconciliation Tool Security Set Up 
• Navigate to your extracted Roster Reconciliation folder. 
• Right click the Excel tool file, select Properties, check Unblock, then click Apply and OK. 
• Open the file in Excel. If you are prompted with a security warning that some active content is 

disabled, click Enable Content > (if prompted) and click Yes to make the file a trusted document 
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• Save and close the file, then reopen it to confirm no further security warnings appear. 

EMR Report Preparation 
Use your EMR to create individual lists of active, rostered patients for each provider who requires roster 
reconciliation. 

Important: Select Your EMR System 
This section is organized by individual EMRs. Please navigate to the subsection relevant to your EMR 
system: 

• OSCAR PRO 
• QHR ACCURO® 
• TELUS CHR 
• TELUS PSS 

 
The EMR Report tools created by OntarioMD for TELUS PSS, QHR ACCURO® and OSCAR PRO include 
default criteria that should be modified to match your clinic’s Patient Status and Roster Status 
definitions. TELUS CHR users will need to create a report in their EMR aligned with these definitions. 

Tip: When updating EMR Report tool criteria, using IS or Equals is generally more precise than Contains to avoid 
non-relevant statuses where a word appears within another status (if applicable to your EMR). 

Tip: After the initial roster clean up, as a supplemental step, clinics may wish to also run an EMR search for all 
patients or all active patients assigned to a physician who are not rostered/enrolled, and process results through the 
roster reconciliation tool to help flag potential enrollment opportunities. 

The EMR Report exported from your EMR will save as CSV or TXT files and will need to be converted to an 
Excel Workbook (XLSX) before importing it into the Roster Reconciliation Tool. 

To easily distinguish between CSV, TXT and XLSX files, enable file extensions in your folder view:  
File Explorer > View > Show > File name extensions. 

Important: Ensure all exported reports are handled securely, managed appropriately, and deleted in accordance 
with your organization’s policies and privacy guidelines. Confirm the download location and consult IT if needed. It’s 
recommended to test the export first using test patient data.  
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OSCAR PRO: Report by Template (RbT) 
Import the Report by Template (RbT) included in the Roster Reconciliation Toolkit, then generate and 
export the EMR report. 

Reminder: After successfully importing or saving the applicable search files into your EMR, you may delete them 
from your locally saved Roster Reconciliation folder. 
 
Tip: Enable File name extensions in folder view to easily distinguish between CSV and XLSX files. 

Import the Report by Template (RbT), Generate and Export the EMR Report in OSCAR PRO 
Important: Before exporting, make sure you know where the report will download on your device. If uncertain, check 
with your IT team and run a test export with test patient data before proceeding. 

1. In OSCAR PRO, from the main menu, click Administration > Reports > Report by Template 
(RbT). 

2. In the Report by Template (RbT) window, click Add Template > Choose File 
3. Browse to and open your locally saved Roster Reconciliation folder, select the OMD Roster 

Reconciliation-EMR Report – OSCAR PRO.TXT > click Open > Upload & Add. 
If successful, a Saved Successfully message will display in the Report by Template (RbT) window. 

4. Locate and select the downloaded Report by Template (RbT) in the list, choose the physician to 
reconcile from the Provider Number dropdown > click Run Query. 

5. To export the patient list, click Export to CSV. 

 
6. Locate the downloaded CSV file on your computer and move the file to the EMR Report subfolder 

inside your locally saved Roster Reconciliation folder. 
7. This CSV file will need to be converted to an Excel workbook (covered in next section). 

Convert the OSCAR PRO EMR Report 
Important: Ensure all exported reports are securely handled, managed, and deleted according to your 
organization’s policies and privacy guidelines. 

1. Navigate to the EMR Report subfolder in your locally saved Roster Reconciliation folder. 
2. Open the CSV in Excel 

a. Option 1: Double-click the CSV file and confirm the data appears in separate columns. 
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b. Option 2: 
i. Open Excel > click Data > select Import from Text/CSV. 

ii. Navigate to your EMR Report subfolder. 
iii.  Select the CSV file and confirm the data appears in separate columns. 

If column layout is incorrect, use the Transform Data option to adjust formatting. 
iv. Click Load.  

3. Save as Excel Workbook 
a. Once the data displays correctly, click File > Save As. 
b. Rename the file (optional i.e.: DR. X - Aug - Converted), choose Excel workbook (*XLSX) as 

the file type, and save it in the EMR Report subfolder. 
Next step: Ministry of Health (MOH) Roster Capitation Report Download 

QHR ACCURO®: Query 
Download query OMD Roster Reconciliation-EMR Report created by OntarioMD from the QHR 
ACCURO® Alert Publisher. 

Tip: Enable File name extensions in folder view to easily distinguish between CSV and XLSX files. 

Download the Query in QHR ACCURO®: 
1. In Accuro, click the Accuro Menu > hover on Reports > click Query Builder (Alerts). 
2. In the Alert Definitions window, click the Cloud icon (Alert Publisher). 
3. In the Alert Definition Publisher window, type Roster Reconciliation into the Search field. 
4. In the Publisher field, select OntarioMD. 
5. Click the magnifying glass to search the repository. 
6. Highlight the query to download. 
7. Click Download Alert. 
8. Click OK when you see the Alert downloaded successfully message. 

Modify and Run the Downloaded Query in QHR ACCURO®: 
 
Tip: When updating EMR Report tool criteria, using IS or Equals is generally more precise than Contains to avoid 
non-relevant statuses where a word appears within another status (if applicable to your EMR). 

1. In Accuro, click the Accuro Menu > hover on Reports > click Query Builder (Alerts). 
2. In the Alert Definitions window, find and select the downloaded query Roster Reconciliation. 
3. Modify query criteria to match your clinic’s Patient Status and Roster Status definitions: 

To update Patient Status (default is Active): 
o Click the rule for Patient Status to select it. 
o Click the magnifying glass icon, search or select your clinic’s patient status(es), and 

click Update Rule. 
To update Enrolled Provider: 

o Click the rule for Enrolled Provider to select it. 
o Choose your physician from the dropdown and click Update Rule. 
 
Note: Avoid filters like Contains: Active which would include inactive patients. 
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4. Once the query is updated for your clinic, click Run Report > Run. 
5. Upon completion, a patient list matching the query criteria will display in the Alert Matches which 

you will need to export (covered in next section). 

Export the QHR ACCURO® EMR Report 
Important: Before exporting, make sure you know where the report will download on your device. If uncertain, check 
with your IT team and run a test export with test patient data before proceeding. 

1. With the Alert Matches/patient list for your rostered physician displayed, click Export 

 

2. In the Export Result window: 
• Deselect Encrypt > click No when prompted to confirm. 
• Click the Ellipsis (…) icon, find and open the EMR Report subfolder inside your locally 

saved Roster Reconciliation folder. 
• Enter a File Name for your output file (i.e.: DR. X - Aug) > click Open. 
• Click Export > if successful, an Export Completed message will appear > click OK. 
 
Note: Ensure you are saving to your local computer, not the QHR ACCURO® server or session. 
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3. A CSV version of the EMR report should now be in the EMR Report subfolder. 
4. This CSV file will need to be converted to an Excel workbook (covered in next section). 

Convert the QHR ACCURO® EMR Report 
Important: Ensure all exported reports are securely handled, managed, and deleted according to your 
organization’s policies and privacy guidelines. 

1. Navigate to the EMR Report subfolder in your locally saved Roster Reconciliation folder. 
2. Open the CSV in Excel 

a. Option 1: Double click the CSV file and confirm the data appears in separate columns. 
b. Option 2: 

i. Open Excel > click Data > select Import from Text/CSV. 
ii. Navigate to your EMR Report subfolder. 

iii.  Select the CSV file and confirm the data appears in separate columns. 
If column layout is incorrect, use the Transform Data option to adjust formatting. 

iv. Click Load.  
3. Save as Excel Workbook 

a. Once the data displays correctly, click File > Save As. 
b. Rename the file (optional i.e.: DR. X - Aug - Converted), choose Excel workbook (*XLSX) as 

the file type, and save it in the EMR Report subfolder. 
Next step: Ministry of Health (MOH) Roster Capitation Report Download 

 

TELUS CHR: Analytics Dashboards 
Within the Analytic Module of the EMR, define analytic dashboard filters, generate and export the EMR 
report. 

Tip: Enable File name extensions in folder view to easily distinguish between CSV and XLSX files. 

Define Analytic Dashboard Filters, Generate and Export the EMR Report in TELUS CHR 
Important: Before exporting, make sure you know where the report will download on your device. If uncertain, check 
with your IT team and run a test export with test patient data before proceeding. 

1. In TELUS CHR, from the main menu, click Analytics  
2. Under Dashboards, search for and select Patient Search. 
3. The Patient Search and filters will load. 
4. Set the Patient Search Filters as follows: 

• Primary Physician: choose IS and select the physician to reconcile from the any value 
dropdown 

• Patient Status: choose IS and select Active or your clinic’s equivalent, from the any 
value dropdown  

• 1. Patient Data Field: choose IS, start typing Enrollment and select 
Enrollment|Enrollment|Status from the any value dropdown. 

• 1. Patient Data Value: choose Contains, start typing Enrollment and select the 
enrollment status(es) matching your clinic’s definitions from the any value dropdown. 
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5. With the filters applied, click the Load or Reload icon to generate the patient list.

 

6. To export the patient list, click the menu icon (Dashboard Actions). 

 
7. In the Download Patient Search window, select CSV as the format > click Download. 
8. Locate the downloaded zipped CSV file on your computer, unzip/extract it, and move the 

extracted search report (patient_search.csv) to the EMR Report subfolder inside your locally 
saved Roster Reconciliation folder. 

9. This CSV file will need to be converted to an Excel workbook (covered in next section). 

Convert the TELUS CHR Analytics Dashboard EMR Report 
Important: Ensure all exported reports are securely handled, managed, and deleted according to your 
organization’s policies and privacy guidelines. 

1. Navigate to the EMR Report subfolder in your locally saved Roster Reconciliation folder.  
2. Open the CSV in Excel 

a. Option 1: Double click the CSV file and confirm the data appears in separate columns. 
b. Option 2: 

i. Open Excel > click Data > select Import from Text/CSV. 
ii. Navigate to your EMR Report subfolder. 

iii.  Select the CSV file and confirm the data appears in separate columns. 
If column layout is incorrect, use the Transform Data option to adjust formatting. 

iv. Click Load. 
3. Save as Excel Workbook 

a. Once the data displays correctly, click File > Save As. 
b. Rename the file (optional i.e.: DR. X - Aug - Converted), choose Excel workbook (*XLSX) as 

the file type, and save it in the EMR Report subfolder. 
Next step: Ministry of Health (MOH) Roster Capitation Report Download 
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TELUS PSS: Search 
Import the search included in the Roster Reconciliation Toolkit then generate and export the EMR report, 

Reminder: After successfully importing or saving the applicable search files into your EMR, you may delete them 
from your locally saved Roster Reconciliation folder. 
 
Tip: Enable File name extensions in folder view to easily distinguish between CSV, TXT and XLSX files. 

Import the Search in TELUS PSS: 
1. In TELUS PSS, from the Records window, click Settings > Edit Searches.

 
2. In the new window that opens, click Edit > Import Searches. 

 
3. Using the dropdown menu, find and open your locally saved Roster Reconciliation folder, select 

OMD Roster Reconciliation-EMR Report – TELUS PSS.srx. 
4. Click Choose. 
5. Once imported, a window will display Successfully Imported. 
6. Click OK. 

Modify and Run the Downloaded Search in TELUS PSS: 
1. In TELUS PSS, from the Records window, click Settings > Edit Searches. 
2. Locate and select the downloaded search in the list. 
3. Modify search criteria to match your clinic’s Patient Status and Roster Status definitions: 

To update Patient Status (default is Active): 
o Click the rule for Patient Status to select it. 
o Click Edit Line, select your clinic’s patient status from the dropdown. 
o Click OK. 
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To update Roster Status (Member Status): 
o Click the rule for Member Status to select it. 
o Click Edit Line, choose the Roster Status (Member Status) your clinic uses from the 

dropdown. 
o Click OK. 
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4. Click Perform Search. 

 

5. Uncheck All Doctors and select the Doctor to reconcile. 
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6. Click Search. 

Export the TELUS PSS EMR Report 
Important: Before exporting, make sure you know where the report will download on your device. If uncertain, check 
with your IT team and run a test export with test patient data before proceeding. 

1. With the patient list for your rostered physician displayed, click Report > Utilities > Save as CSV. 
Note: The EMR outputs a TXT file rather than CSV; its file extension will be changed to CSV in the next steps. 
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2. In the Save list as window: 

a. Find and open the EMR Report subfolder inside your locally saved Roster Reconciliation 
folder. 

b. Enter a File Name in the Object Name field (i.e.: DR. X - Aug) > click Save. 
 

Note: If you use remote desktop to access TELUS PSS, ensure you save to your local computer - not the TELUS PSS 
server or session - or move the saved file afterward to the EMR Report subfolder inside your locally saved Roster 
Reconciliation folder. 

 
3. A TXT (or CSV) version of the EMR report should now be in the EMR Report subfolder. 
4. This TXT file will need to be changed to CSV, then converted to an Excel workbook (covered in next 

section). 

Convert the TELUS PSS EMR Report 
Important: Ensure all exported reports are securely handled, managed, and deleted according to your 
organization’s policies and privacy guidelines. 
 

1. Navigate to the EMR Report subfolder in your locally saved Roster Reconciliation folder. 
2. Change the file extension from TXT to CSV. 
3. Open the CSV in Excel: 

a. Double click the CSV file to open in Excel. 
b. Confirm the data appears in separate columns. 
c. Delete the blank top row (if present). 

4. Save as Excel Workbook. 
a. Click File > Save As. 
b. Rename the file (optional i.e.: DR. X - Aug - Converted), choose Excel workbook (*XLSX) as 

the file type, and save it in the EMR Report subfolder. 
Next step: Ministry of Health (MOH) Roster Capitation Report Download 
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Ministry of Health (MOH) Roster Capitation Report Download 
The Ministry of Health (MOH) Roster Capitation files can be downloaded from the OPS BPS Secure portal 
(or accessed directly from your EMR if available). 

Follow these steps to download the required Roster Capitation file(s): 
1. Log in to the Medical Claims Electronic Data Transfer (MC EDT) system via the OPS BPS Secure 

portal. 
2. Select the MC EDT Service (Report Download) option. 

 
3. In the dropdown menus, select the Physician Name/Billing Number to reconcile and the MC EDT 

Service (Upload/Download) > click Access Service. 
4. Locate the physician’s most recent Roster Capitation Report (XML format). 
5. Click Download and save the XML file to the MOH Report subfolder within your Roster 

Reconciliation folder (if it downloads automatically, locate it on your computer and move it there). 
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6. Repeat the process for each physician to reconcile. 
Tip: The Roster Capitation Report(s) include the physician’s billing number in the file name. To avoid confusion, you 
can save it with a clear name such as Dr. X-Roster-Aug2025.xml when downloading. 

Important: The Roster Capitation Report is available as both a PDF and an XML file. The Roster Reconciliation tool 
requires using the XML version. 

Roster Reconciliation Tool Usage 
Important: Before starting, ensure macros/content are enabled, unblock/trust the file (see Roster Reconciliation 
Tool Security Set Up), and you are running the tool from your local computer. 

1. Open the Roster Reconciliation Tool in Excel. 
2. Click Select EMR file > browse to the EMR Report subfolder > select your converted EMR Report 

Excel workbook (.XLSX) > click OK. 
If successful, an EMR File path saved message will appear, and path will be displayed on the spreadsheet. 

3. Click OK. 
4. Click Select MOH file > browse to the MOH Report subfolder > select your Roster Capitation Report 

(XML) > click OK. 
If successful, a File path saved message will appear, and path will be displayed on the spreadsheet. 
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5. Click OK. 
6. Enter the column header names from your EMR Report for patient name and health card number into 

the fields Field with Name and Field with HN (must match exactly). 
 

Column Header Names by EMR (Using the OntarioMD EMR Report Tools) 

EMR Field with Name Field with HN 

OSCAR PRO Last Name HCN 

QHR ACCURO ® Last Name PHN 

TELUS CHR Patient Full Name Patient Identification Value 

TELUS PSS Surname Health Number 

 
7. Click Extract to load the data. 

If successful, you will see the following in sequence: 
• MOH XML data extracted and table created successfully, and the path will be displayed on the 

spreadsheet > click OK. 
• EMR Report briefly opens and closes. 
• EMR data processed successfully (VBA method) > click OK. 
• Data extraction completed successfully > click OK. 

8. Once extraction is successful, click Compare to run the reconciliation. 
9. Upon completion, three patient lists will populate the Roster Reconciliation worksheet. 
10. Save the roster cleanup lists:  

File > Save a Copy (or Save As) in the Reconciliation Cleanup – TO DO subfolder.  
(i.e.: Dr. X - roster cleanup to do – Aug2025) 

11. The saved copy of the physician’s roster cleanup file will be in the Reconciliation Cleanup – TO DO 
subfolder for later review or delegation. 

 
Important: Ensure all exported reports are handled securely, managed appropriately, and deleted in accordance 
with your organization’s policies and privacy guidelines. 
 
12. Reset the tool for new use: 

• Reopen the tool from your locally saved Roster Reconciliation folder; the data should be cleared. 
• If not, click Clear All Data. 
• If the issue persists, confirm the cleanup report was saved to the Reconciliation Cleanup – TO 

DO folder; if not, regenerate and resave it. 
13. If needed, repeat the process for new reconciliation tasks. 
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Reviewing and Acting on Findings 
The Roster Reconciliation Tool produces three output lists to guide your follow-up actions, including: 

• Patients on your EMR roster who are not found on the MOH roster (per EMR search criteria) 
(possible de-rostered patients or incorrectly marked as rostered in the EMR) 

• Patients on the MOH roster who are not enrolled/rostered in your EMR (per EMR search criteria) 
(may require re-enrollment, review for potential billing errors, or updating of EMR record for roster) 

• Recent roster termination(s) 
 

Review these lists carefully with your clinic team. Follow up as needed - this may include patient contact, 
enrollment updates, or billing adjustments. 

Tip: Many physicians perform roster reconciliation quarterly or semi-annually as a best practice for panel 
management. 

Tip: After the initial roster clean up, as a supplemental step, clinics may wish to also run an EMR search for all 
patients or all active patients assigned to a physician who are not rostered/enrolled, and process results through the 
roster reconciliation tool to help flag potential enrollment opportunities. 
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Additional Resources & References 
• OPS BPS Secure portal. Access to Ministry of Health MC EDT system. https://bps.ops.gov.on.ca 
• Dr. Kevin Brophy & Dr. Alex Duong. Developers of the Roster Reconciliation Tool, supported by the 

Ontario Medical Association (OMA), OntarioMD, and the OMA’s Section on General and Family 
Practice (SGFP). 

• OntarioMD. Roster Reconciliation Toolkit, including EMR Report Tools, Roster Reconciliation 
guidance, and the Roster Reconciliation Tool (developed by Brophy & Duong) for OSCAR PRO, QHR 
ACCURO®, TELUS CHR, and TELUS PSS. Available on OMD Educates. 
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